Bug 1042

Summary: AODV RERR implosion (missing RERR_RATELIMIT)
Product: ns-3 Reporter: Morten Lindeberg <mglindeb>
Component: aodvAssignee: Elena Buchatskaya <sunnmy>
Status: RESOLVED FIXED    
Severity: normal CC: mglindeb, ns-bugs, tomh
Priority: P5    
Version: ns-3-dev   
Hardware: Mac Intel   
OS: Mac OS   
Attachments: patch to fix

Description Morten Lindeberg 2011-01-13 09:09:07 EST
Overview:

We have successfully deployed our delay tolerant overlay (Dts-Overlay - still unpublished work) over OLSR and DSDV in a disruptive MANET setting using ns-3.10. However, we run into problems with AODV. In our custom mobility model, designated message ferries travel between two network partitions. Upon one node leaving the partition, our simulations halts and progress extremely slow forwards in time. We have found the cause to be an excessive amount of AODV route error messages being broadcasted from all affected nodes at an extreme rate.

As an example from one specific node, two equal RERR messages are sent with only 0.000378 seconds between from the same node. 

(Unreachable destination (ipv4 address, seq. number): 10.0.1.1, 19, No delete flag: 0.)
(Unreachable destination (ipv4 address, seq. number): 10.0.1.1, 19, No delete flag: 0.)

According to the specification (RFC35621, p 20), there should exist a rate limit for route error messages (RERR_RATELIMIT). I could not find this in the AODV implementation, although it seems there exist a limit (implemented using a Timer) for route requests (RREQs).
Comment 1 Tom Henderson 2011-05-12 09:40:41 EDT
Created attachment 1110 [details]
patch to fix

Elena previously sent a patch for this which I tested and appears to provide the required rate limiting.
Comment 2 Tom Henderson 2011-05-13 02:16:30 EDT
changeset: 009cd4e1b486