Bug 2212

Summary: assert failed, "did not find libstdc++.so.6"
Product: dce Reporter: Alan <ithinkwemet>
Component: otherAssignee: Hajime Tazaki <tazaki>
Status: NEW ---    
Severity: normal CC: ns-bugs
Priority: P5    
Version: unspecified   
Hardware: Other   
OS: Linux   

Description Alan 2015-11-09 12:20:22 EST
I'm attempting to get the ns3 dce running on an ARM device (UDOO running debian) using these instructions.
https://www.nsnam.org/docs/dce/manual/html/getting-started.html

When I run the dce-udp-simple example I get the following output and error message.


Waf: Entering directory `/var/ns3/dce/source/ns-3-dce/build'

--------------------------------------------------------------------
 Python bindings compilation
--------------------------------------------------------------------
[ 10/322] lib/pkgconfig/libns3-dev-netlink-debug.pc:  -> build/lib/pkgconfig/libns3-dev-netlink-debug.pc
[111/322] lib/pkgconfig/libns3-dev-dce-debug.pc:  -> build/lib/pkgconfig/libns3-dev-dce-debug.pc
Waf: Leaving directory `/var/ns3/dce/source/ns-3-dce/build'
'build' finished successfully (2.264s)
assert failed. cond="false", msg="did not find libstdc++.so.6", file=../model/elf-cache.cc, line=315
terminate called without an active exception
Command ['/var/ns3/dce/source/ns-3-dce/build/bin/dce-udp-simple'] terminated with signal SIGIOT. Run it under a debugger to get more information (./waf --run <program> --command-template="gdb --args %s <args>").

ldconfig -p shows that libstdc++.so.6 is in /usr/lib/arm-linux-gnueabihf/