Bug 404

Summary: ErrorModel attribute name is not consistent across devices
Product: ns-3 Reporter: Tom Henderson <tomh>
Component: devicesAssignee: Craig Dowell <craigdo>
Status: RESOLVED FIXED    
Severity: normal CC: ns-bugs
Priority: P2    
Version: ns-3-dev   
Hardware: All   
OS: All   

Description Tom Henderson 2008-11-07 10:39:22 EST
IMO, the name of this attribute should be aligned across devices, even though it is an API change.

In PointToPoint:
                   .AddAttribute ("ReceiveErrorModel",
                   "The receiver error model used to simulate packet loss",
                   PointerValue (),
                   MakePointerAccessor (&PointToPointNetDevice::m_receiveErrorModel),
                   MakePointerChecker<ErrorModel> ())

In CSMA:
                   .AddAttribute ("RxErrorModel",
                   "The receiver error model used to simulate packet loss",
                   PointerValue (),
                   MakePointerAccessor (&CsmaNetDevice::m_receiveErrorModel),
                   MakePointerChecker<ErrorModel> ())

(Note:  there presently is no ReceiveErrorModel in Bridge, SimpleNetDevice, or Wifi.  I would also propose to add this attribute to SimpleNetDevice, at the very least, once the naming alignment is settled.  Is there a reason why not to include in all current NetDevices?)