Bug 2426 - TCP congestion with no dropping packets
TCP congestion with no dropping packets
Product: dce
Classification: Unclassified
Component: quagga
PC Linux
: P5 enhancement
Assigned To: Hajime Tazaki
Depends on:
  Show dependency treegraph
Reported: 2016-06-01 00:08 EDT by bright_yuen126
Modified: 2016-06-01 01:17 EDT (History)
1 user (show)

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description bright_yuen126 2016-06-01 00:08:16 EDT
I'm trying to build a topology with a bottleneck like this:
        |     10Mbps
      /   \   100Mbps
     /     \
   node3  node4
then I run iperf -s on node 1 and iperf -c on node 3 and 4.

What confuse me is that although the speed of tcp transmission is lower down on both nodes, no packet loss(drop) is recorded in the .tr file.

I'm running dce-quagga and the ip-table is static.

Can anyone give some explaination?
Comment 1 bright_yuen126 2016-06-01 01:17:39 EDT
Sorry for my carelessness, the problem has been solved.
I edited the source code of iperf which induced some error limiting the speed.

Thanks to all.