Bug 766 - doxygen updates for QoS/EDCA
doxygen updates for QoS/EDCA
Status: RESOLVED DUPLICATE of bug 938
Product: ns-3
Classification: Unclassified
Component: documentation
pre-release
All All
: P5 minor
Assigned To: Nicola Baldo
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-03 16:53 EST by Michael Nowatkowski
Modified: 2015-03-01 05:29 EST (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Nowatkowski 2009-12-03 16:53:06 EST
From Nicola Baldo:

when EDCA is used, UserPriority values are equal to TID values, as
specified by the doxygen documentation. The enum UserPriority has been
recently introduced because it is defined by the standard and it is
more meaningful for the users than hard-coded TID values (though TID
values still must be specified when HDCA is used instead of EDCA).

UserPriority is the value that the application sets for the QosTag.
QosTag translates UserPriority into the corresponding TID. Then the
MAC will translate the TID value into the corresponding AccessClass.
The mapping is defined by the standard, and is implemented in src/
devices/wifi/qos-utils.{h,cc}. I understand that the mapping functions
in these latter files do not appear in the doxygen documentation. It
would be great if you could file a bug report on this issue, so that
we can keep track of it.

Also, there is no doxygen for the QoS wifi mac models (qadhoc, qap, and qsta).
Comment 1 Ruben Merz 2011-06-01 19:54:35 EDT
Is this bug report still valid after the WifiMac rewrite?
Comment 2 Tommaso Pecorella 2015-03-01 05:29:38 EST
(In reply to Ruben Merz from comment #1)
> Is this bug report still valid after the WifiMac rewrite?

Closing this bug. Any doxygen missing feature is already included in bug #938

*** This bug has been marked as a duplicate of bug 938 ***